CVE-2017-1000244 Jenkins Favorite Plugin vulnerable to Cross-Site Request Forgery

High 8.8 Published Updated

Attackers can force authenticated users to modify data via CSRF in the Jenkins Favorite Plugin.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000244?

CVE-2017-1000244 is a high-severity vulnerability in n/a, published on 1 Nov 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Jenkins Favorite Plugin version 2.2.0 and older is vulnerable to CSRF resulting in data modification

Weakness: CWE-352

Which versions are affected by CVE-2017-1000244?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:favorite. It affects 1 product.

PackageAffectedFixed in
org.jvnet.hudson.plugins:favorite MavenAll versions2.3.2
org.jvnet.hudson.plugins:favorite MavenAll versions2.3.2

Products include Jenkins Favorite.

How do I fix CVE-2017-1000244?

Upgrade org.jvnet.hudson.plugins:favorite to 2.3.2 or later.

Is CVE-2017-1000244 being exploited?

There is no known exploitation of CVE-2017-1000244 in the wild and no public exploit code.

Sources

Also known as GHSA-jqwh-jrpg-5j3h.

Is CVE-2017-1000244 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free