{"answers":{"affected":"3 open source packages ship an affected version, including pysaml2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000246 in the wild and no public exploit code.","fix":"Upgrade pysaml2 to 4.6.0 or later.","what":"CVE-2017-1000246 is a medium-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000246 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000246 is a medium-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000246 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pysaml2 (PyPI): affected all versions; fixed in 4.6.0\n- pysaml2 (PyPI): affected all versions; fixed in 4.6.0\n- pysaml2 (PyPI): affected all versions; fixed in 4.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000246/ (Markdown: https://insights.sbomify.com/CVE-2017-1000246/index.md)","id":"CVE-2017-1000246","markdown":"https://insights.sbomify.com/CVE-2017-1000246/index.md","name":"CVE-2017-1000246","record":{"aliases":["DEBIAN-CVE-2017-1000246","GHSA-cq94-qf6q-mf2h","PYSEC-2017-26","UBUNTU-CVE-2017-1000246"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Python SAML library","requires_auth":"none","summary":"Attackers can decrypt sensitive data due to IV reuse in pysaml2 IDP server encryption, affecting applications using this library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pysaml2","vendor":"pysaml2_project"}],"cvss":{"score":5.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-330","name":"Use of Insufficiently Random Values"}],"description":"Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pysaml2 improperly initializes encryption vector","id":"CVE-2017-1000246","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"weak_cryptography","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"CodeIgniter HTTP Header Injection","id":"CVE-2017-1000247"},"packages":[{"ecosystem":"PyPI","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":null,"source":"GHSA-cq94-qf6q-mf2h"},{"ecosystem":"PyPI","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"GHSA-cq94-qf6q-mf2h"},{"ecosystem":"PyPI","fixed":["4.6.0"],"introduced":["0"],"last_affected":[],"package":"pysaml2","purl":"pkg:pypi/pysaml2","source":"PYSEC-2017-26"}],"prev":{"headline":"Jenkins SSH Plugin user passwords for encrypted SSH keys stored in plaintext","id":"CVE-2017-1000245"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":9,"headline":"PySAML2 XML external entity attack","id":"CVE-2016-10127","kev_date_added":null,"published":"2017-03-03"},{"cvss_score":6.5,"headline":"SAML XML Signature wrapping","id":"CVE-2021-21238","kev_date_added":null,"published":"2021-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can decrypt sensitive data due to IV reuse in pysaml2 IDP server encryption, affecting applications using this library.","url":"https://insights.sbomify.com/CVE-2017-1000246/"}