# CVE-2017-1000246: Pysaml2 improperly initializes encryption vector

> Attackers can decrypt sensitive data due to IV reuse in pysaml2 IDP server encryption, affecting applications using this library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2017
- **Updated:** 17 Sep 2024
- **Also known as:** DEBIAN-CVE-2017-1000246, GHSA-cq94-qf6q-mf2h, PYSEC-2017-26, UBUNTU-CVE-2017-1000246

## What is CVE-2017-1000246?

CVE-2017-1000246 is a medium-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.

Weakness: CWE-330 (Use of Insufficiently Random Values)

## Which versions are affected by CVE-2017-1000246?

3 open source packages ship an affected version, including pysaml2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pysaml2` | PyPI | All versions | 4.6.0 |
| `pysaml2` | PyPI | All versions | 4.6.0 |
| `pysaml2` | PyPI | All versions | 4.6.0 |

Products: Pysaml2 Project Pysaml2.

## How do I fix CVE-2017-1000246?

Upgrade pysaml2 to 4.6.0 or later.

## Is CVE-2017-1000246 being exploited?

There is no known exploitation of CVE-2017-1000246 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-10127](https://insights.sbomify.com/CVE-2016-10127/): PySAML2 XML external entity attack (critical 9.0)
- [CVE-2021-21238](https://insights.sbomify.com/CVE-2021-21238/): SAML XML Signature wrapping (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000246 and fix it if it is affected.

What it is: CVE-2017-1000246 is a medium-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000246 in the wild and no public exploit code.

Affected packages and fixed versions:
- pysaml2 (PyPI): affected all versions; fixed in 4.6.0
- pysaml2 (PyPI): affected all versions; fixed in 4.6.0
- pysaml2 (PyPI): affected all versions; fixed in 4.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000246/ (Markdown: https://insights.sbomify.com/CVE-2017-1000246/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000246
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000246
- OSV: https://osv.dev/vulnerability/CVE-2017-1000246

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000246/
Summaries are generated and may contain mistakes; the official description above is the record.
