{"answers":{"affected":"2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000247 in the wild and no public exploit code.","fix":"Upgrade codeigniter4/framework to 3.1.4 or later.","what":"CVE-2017-1000247 is a high-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000247 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000247 is a high-severity vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000247 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- codeigniter4/framework (Packagist): affected from 3.1.3; fixed in 3.1.4\n- codeigniter4/framework (Packagist): affected from 3.1.3; fixed in 3.1.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000247/ (Markdown: https://insights.sbomify.com/CVE-2017-1000247/index.md)","id":"CVE-2017-1000247","markdown":"https://insights.sbomify.com/CVE-2017-1000247/index.md","name":"CVE-2017-1000247","record":{"aliases":["GHSA-j9f9-8j39-4g97"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"CodeIgniter framework","requires_auth":"none","summary":"Attackers can inject HTTP headers via the set_status_header function in CodeIgniter, potentially bypassing security controls or causing response splitting.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"codeigniter","vendor":"codeigniter"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"British Columbia Institute of Technology CodeIgniter 3.1.3 is vulnerable to HTTP Header Injection in the set_status_header() common function under Apache resulting in HTTP Header Injection flaws.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CodeIgniter HTTP Header Injection","id":"CVE-2017-1000247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"other","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"redis-store deserializes untrusted data","id":"CVE-2017-1000248"},"packages":[{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.1.3"],"last_affected":[],"package":"codeigniter4/framework","purl":null,"source":"GHSA-j9f9-8j39-4g97"},{"ecosystem":"Packagist","fixed":["3.1.4"],"introduced":["3.1.3"],"last_affected":[],"package":"codeigniter4/framework","purl":"pkg:composer/codeigniter4/framework","source":"GHSA-j9f9-8j39-4g97"}],"prev":{"headline":"Pysaml2 improperly initializes encryption vector","id":"CVE-2017-1000246"},"products":["n/a"],"published":"2017-11-17","related":[{"cvss_score":9.8,"headline":"CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability","id":"CVE-2025-54418","kev_date_added":null,"published":"2025-07-28"},{"cvss_score":9.8,"headline":"Remote Code Execution Vulnerability in Validation Placeholders","id":"CVE-2023-32692","kev_date_added":null,"published":"2023-05-30"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40824","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40825","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40826","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40827","kev_date_added":null,"published":"2022-10-07"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2022-40828","kev_date_added":null,"published":"2022-10-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can inject HTTP headers via the set_status_header function in CodeIgniter, potentially bypassing security controls or causing response splitting.","url":"https://insights.sbomify.com/CVE-2017-1000247/"}