CVE-2017-1000248 redis-store deserializes untrusted data

Critical 9.8 Published Updated

An attacker can execute arbitrary code by sending malicious serialized objects to the Redis store library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000248?

CVE-2017-1000248 is a critical unsafe deserialization vulnerability in n/a, published on 17 Nov 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Redis-store <=v1.3.0 allows unsafe objects to be loaded from redis

Weakness: CWE-502

Which versions are affected by CVE-2017-1000248?

2 open source packages ship an affected version, including redis-store. It affects 1 product.

PackageAffectedFixed in
redis-store RubyGemsAll versions1.4.0
redis-store RubyGemsAll versions1.4.0

Products include Redis-Store Redis-Store.

How do I fix CVE-2017-1000248?

Upgrade redis-store to 1.4.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2017-1000248 being exploited?

There is no known exploitation of CVE-2017-1000248 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2017-1000248, GHSA-2w67-526p-gm73, UBUNTU-CVE-2017-1000248.

Is CVE-2017-1000248 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free