# CVE-2017-1000353: Jenkins Remote Code Execution

> Unauthenticated attackers can execute arbitrary code on Jenkins servers by exploiting a deserialization flaw in the CLI protocol.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 2 Oct 2025 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2018
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-26wc-3wqp-g3rp

## What is CVE-2017-1000353?

CVE-2017-1000353 is a critical unsafe deserialization vulnerability in Jenkins Jenkins, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an unauthenticated remote code execution. An unauthenticated remote code execution vulnerability allowed attackers to transfer a serialized Java `SignedObject` object to the Jenkins CLI, that would be deserialized using a new `ObjectInputStream`, bypassing the existing blacklist-based protection mechanism. We're fixing this issue by adding `SignedObject` to the blacklist. We're also backporting the new HTTP CLI protocol from Jenkins 2.54 to LTS 2.46.2, and deprecating the remoting-based (i.e. Java serialization) CLI protocol, disabling it by default.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2017-1000353?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.46.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.46.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.57 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.57 |

Products: Jenkins Jenkins, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2017-1000353?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.46.2 or 2.57. US federal agencies must fix it by 23 Oct 2025.

## Is CVE-2017-1000353 being exploited?

Yes. Attackers have exploited CVE-2017-1000353 in the wild since at least 2 Oct 2025.

Public exploit code:

- jenkins CVE-2017-1000353 POC (github_poc): https://github.com/vulhub/CVE-2017-1000353
- https://github.com/r00t4dm/Jenkins-CVE-2017-1000353 (github_poc): https://github.com/r00t4dm/Jenkins-CVE-2017-1000353
- Jenkins CLI Deserialization (metasploit)
- CloudBees Jenkins 2.32.1 - Java Deserialization (exploitdb)

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)
- [CVE-2021-21691](https://insights.sbomify.com/CVE-2021-21691/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000353 and fix it if it is affected.

What it is: CVE-2017-1000353 is a critical unsafe deserialization vulnerability in Jenkins Jenkins, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2017-1000353 in the wild since at least 2 Oct 2025.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000353/ (Markdown: https://insights.sbomify.com/CVE-2017-1000353/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000353
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000353
- OSV: https://osv.dev/vulnerability/CVE-2017-1000353

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000353/
Summaries are generated and may contain mistakes; the official description above is the record.
