# CVE-2017-1000354: Improper Authentication in Jenkins

> Attackers with specific permissions can impersonate any Jenkins user by exploiting a flaw in the CLI login command's credential caching mechanism.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r57f-7xw3-q2r9

## What is CVE-2017-1000354?

CVE-2017-1000354 is a high-severity authentication bypass vulnerability in Jenkins Jenkins, published on 29 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to a login command which allowed impersonating any Jenkins user. The `login` command available in the remoting-based CLI stored the encrypted user name of the successfully authenticated user in a cache file used to authenticate further commands. Users with sufficient permission to create secrets in Jenkins, and download their encrypted values (e.g. with Job/Configure permission), were able to impersonate any other Jenkins user on the same instance.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-1000354?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.46.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.46.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.57 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.50 | 2.57 |

Products: Jenkins Jenkins.

## How do I fix CVE-2017-1000354?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.46.2 or 2.57.

## Is CVE-2017-1000354 being exploited?

There is no known exploitation of CVE-2017-1000354 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000354 and fix it if it is affected.

What it is: CVE-2017-1000354 is a high-severity authentication bypass vulnerability in Jenkins Jenkins, published on 29 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000354 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000354/ (Markdown: https://insights.sbomify.com/CVE-2017-1000354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000354
- OSV: https://osv.dev/vulnerability/CVE-2017-1000354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000354/
Summaries are generated and may contain mistakes; the official description above is the record.
