CVE-2017-1000355 Deserialization of Untrusted Data in Jenkins

Medium 6.5 Published Updated

Attackers can cause a Java crash and denial of service in Jenkins by exploiting an XStream deserialization vulnerability.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000355?

CVE-2017-1000355 is a medium-severity unsafe deserialization vulnerability in Jenkins Jenkins, published on 29 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an XStream: Java crash when trying to instantiate void/Void.

Weakness: CWE-502

Which versions are affected by CVE-2017-1000355?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.46.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.46.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.502.57
org.jenkins-ci.main:jenkins-core MavenFrom 2.502.57

Products include Jenkins Jenkins.

How do I fix CVE-2017-1000355?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.46.2 or 2.57.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2017-1000355 being exploited?

There is no known exploitation of CVE-2017-1000355 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-4466-8jm4-448p.

Is CVE-2017-1000355 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free