CVE-2017-1000356 Cross-Site Request Forgery in Jenkins
Attackers can exploit CSRF to create admin accounts or delete existing admins if signup is enabled, leading to full system compromise.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-1000356?
CVE-2017-1000356 is a high-severity vulnerability in Jenkins Jenkins, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.
Weakness: CWE-352
Which versions are affected by CVE-2017-1000356?
4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.46.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.46.2 |
org.jenkins-ci.main:jenkins-core Maven | From 2.50 | 2.57 |
org.jenkins-ci.main:jenkins-core Maven | From 2.50 | 2.57 |
Products include Jenkins Jenkins.
How do I fix CVE-2017-1000356?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.46.2 or 2.57.
Is CVE-2017-1000356 being exploited?
There is no known exploitation of CVE-2017-1000356 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as GHSA-85wq-pqhp-hmq6.