{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000356 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.46.2 or 2.57.","what":"CVE-2017-1000356 is a high-severity vulnerability in Jenkins Jenkins, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000356 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000356 is a high-severity vulnerability in Jenkins Jenkins, published on 29 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000356 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.46.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.50; fixed in 2.57\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000356/ (Markdown: https://insights.sbomify.com/CVE-2017-1000356/index.md)","id":"CVE-2017-1000356","markdown":"https://insights.sbomify.com/CVE-2017-1000356/index.md","name":"CVE-2017-1000356","record":{"aliases":["GHSA-85wq-pqhp-hmq6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Jenkins automation server","requires_auth":"none","summary":"Attackers can exploit CSRF to create admin accounts or delete existing admins if signup is enabled, leading to full system compromise.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jenkins","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Jenkins versions 2.56 and earlier as well as 2.46.1 LTS and earlier are vulnerable to an issue in the Jenkins user database authentication realm: create an account if signup is enabled; or create an account if the victim is an administrator, possibly deleting the existing default admin user in the process and allowing a wide variety of impacts.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in Jenkins","id":"CVE-2017-1000356","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins"],"type":"csrf","year":"2017"},"n_packages":4,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2017-1000357"},"packages":[{"ecosystem":"Maven","fixed":["2.46.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-85wq-pqhp-hmq6"},{"ecosystem":"Maven","fixed":["2.46.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-85wq-pqhp-hmq6"},{"ecosystem":"Maven","fixed":["2.57"],"introduced":["2.50"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-85wq-pqhp-hmq6"},{"ecosystem":"Maven","fixed":["2.57"],"introduced":["2.50"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-85wq-pqhp-hmq6"}],"prev":{"headline":"Deserialization of Untrusted Data in Jenkins","id":"CVE-2017-1000355"},"products":["n/a"],"published":"2018-01-29","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can exploit CSRF to create admin accounts or delete existing admins if signup is enabled, leading to full system compromise.","url":"https://insights.sbomify.com/CVE-2017-1000356/"}