CVE-2017-1000376 Memory corruption in n/a
Attackers can trigger arbitrary code execution via stack overwrites due to libffi requesting an executable stack on 32-bit x86 systems.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000376?
CVE-2017-1000376 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.
Weakness: CWE-119
Which versions are affected by CVE-2017-1000376?
It affects 6 products.
Linux distribution packages (6)
gcc43 SUSE:Linux Enterprise Point of Sale 11 SP3 | All versions | 4.3.4_20091019-37.3.1 |
gcc43 SUSE:Linux Enterprise Server 11 SP3-LTSS | All versions | 4.3.4_20091019-37.3.1 |
gcc43 SUSE:Linux Enterprise Server 11 SP3-TERADATA | All versions | 4.3.4_20091019-37.3.1 |
gcc43 SUSE:Linux Enterprise Server 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |
gcc43 SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |
gcc43 SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |
Products include Debian Debian Linux, Libffi Project Libffi, Oracle Peopletools, Redhat Enterprise Linux, Redhat Enterprise Virtualization Server, Redhat Openshift.
How do I fix CVE-2017-1000376?
Upgrade to a fixed version.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2017-1000376 being exploited?
There is no known exploitation of CVE-2017-1000376 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2017-1000376, DLA-997-1, DSA-3889-1, ECHO-284d-d78f-39db, GHSA-8jcm-439f-pj4q, MGASA-2017-0201 and 3 more.