# CVE-2017-1000376: Memory corruption in n/a

> Attackers can trigger arbitrary code execution via stack overwrites due to libffi requesting an executable stack on 32-bit x86 systems.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2017
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1000376, DLA-997-1, DSA-3889-1, ECHO-284d-d78f-39db, GHSA-8jcm-439f-pj4q, MGASA-2017-0201, SUSE-SU-2018:0300-1, UBUNTU-CVE-2017-1000376, USN-3454-1

## What is CVE-2017-1000376?

CVE-2017-1000376 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

libffi requests an executable stack allowing attackers to more easily trigger arbitrary code execution by overwriting the stack. Please note that libffi is used by a number of other libraries. It was previously stated that this affects libffi version 3.2.1 but this appears to be incorrect. libffi prior to version 3.1 on 32 bit x86 systems was vulnerable, and upstream is believed to have fixed this issue in version 3.1.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2017-1000376?

It affects 6 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gcc43` | SUSE:Linux Enterprise Point of Sale 11 SP3 | All versions | 4.3.4_20091019-37.3.1 |
| `gcc43` | SUSE:Linux Enterprise Server 11 SP3-LTSS | All versions | 4.3.4_20091019-37.3.1 |
| `gcc43` | SUSE:Linux Enterprise Server 11 SP3-TERADATA | All versions | 4.3.4_20091019-37.3.1 |
| `gcc43` | SUSE:Linux Enterprise Server 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |
| `gcc43` | SUSE:Linux Enterprise Server for SAP Applications 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |
| `gcc43` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 4.3.4_20091019-37.3.1 |

Products: Debian Debian Linux, Libffi Project Libffi, Oracle Peopletools, Redhat Enterprise Linux, Redhat Enterprise Virtualization Server, Redhat Openshift.

## How do I fix CVE-2017-1000376?

Upgrade to a fixed version.

## Is CVE-2017-1000376 being exploited?

There is no known exploitation of CVE-2017-1000376 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000376 and fix it if it is affected.

What it is: CVE-2017-1000376 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 19 Jun 2017. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000376 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000376/ (Markdown: https://insights.sbomify.com/CVE-2017-1000376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000376
- OSV: https://osv.dev/vulnerability/CVE-2017-1000376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000376/
Summaries are generated and may contain mistakes; the official description above is the record.
