{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:build-publisher. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000387 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:build-publisher to 1.22 or later.","what":"CVE-2017-1000387 is a high-severity vulnerability in n/a, published on 26 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000387 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000387 is a high-severity vulnerability in n/a, published on 26 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000387 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:build-publisher (Maven): affected all versions; fixed in 1.22\n- org.jenkins-ci.plugins:build-publisher (Maven): affected all versions; fixed in 1.22\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000387/ (Markdown: https://insights.sbomify.com/CVE-2017-1000387/index.md)","id":"CVE-2017-1000387","markdown":"https://insights.sbomify.com/CVE-2017-1000387/index.md","name":"CVE-2017-1000387","record":{"aliases":["GHSA-m3wv-fr8v-fmh7"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Jenkins Build-Publisher plugin","requires_auth":"low_privilege","summary":"The Jenkins Build-Publisher plugin stores credentials unencrypted, allowing local attackers or those exploiting XSS to steal sensitive authentication data.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"build-publisher","vendor":"jenkins"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins Build-Publisher plugin version 1.21 and earlier stores credentials to other Jenkins instances in the file hudson.plugins.build_publisher.BuildPublisher.xml in the Jenkins master home directory. These credentials were stored unencrypted, allowing anyone with local file system access to access them. Additionally, the credentials were also transmitted in plain text as part of the configuration form. This could result in exposure of the credentials through browser extensions, cross-site scripting vulnerabilities, and similar situations.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Build-Publisher plugin has Insufficiently Protected Credentials","id":"CVE-2017-1000387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks","id":"CVE-2017-1000388"},"packages":[{"ecosystem":"Maven","fixed":["1.22"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:build-publisher","purl":null,"source":"GHSA-m3wv-fr8v-fmh7"},{"ecosystem":"Maven","fixed":["1.22"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:build-publisher","purl":"pkg:maven/org.jenkins-ci.plugins/build-publisher","source":"GHSA-m3wv-fr8v-fmh7"}],"prev":{"headline":"Cross-site Scripting in Jenkins Active Choices plugin","id":"CVE-2017-1000386"},"products":["n/a"],"published":"2018-01-26","related":[{"cvss_score":8,"headline":"Jenkins build-publisher plugin vulnerable to cross-site request forgery","id":"CVE-2022-41232","kev_date_added":null,"published":"2022-09-21"},{"cvss_score":5.7,"headline":"Path traversal in Jenkins build-publisher Plugin","id":"CVE-2022-41231","kev_date_added":null,"published":"2022-09-21"},{"cvss_score":4.3,"headline":"Missing permission check in Jenkins build-publisher Plugin","id":"CVE-2022-41230","kev_date_added":null,"published":"2022-09-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"The Jenkins Build-Publisher plugin stores credentials unencrypted, allowing local attackers or those exploiting XSS to steal sensitive authentication data.","url":"https://insights.sbomify.com/CVE-2017-1000387/"}