# CVE-2017-1000387: Jenkins Build-Publisher plugin has Insufficiently Protected Credentials

> The Jenkins Build-Publisher plugin stores credentials unencrypted, allowing local attackers or those exploiting XSS to steal sensitive authentication data.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-m3wv-fr8v-fmh7

## What is CVE-2017-1000387?

CVE-2017-1000387 is a high-severity vulnerability in n/a, published on 26 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Build-Publisher plugin version 1.21 and earlier stores credentials to other Jenkins instances in the file hudson.plugins.build_publisher.BuildPublisher.xml in the Jenkins master home directory. These credentials were stored unencrypted, allowing anyone with local file system access to access them. Additionally, the credentials were also transmitted in plain text as part of the configuration form. This could result in exposure of the credentials through browser extensions, cross-site scripting vulnerabilities, and similar situations.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2017-1000387?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:build-publisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:build-publisher` | Maven | All versions | 1.22 |
| `org.jenkins-ci.plugins:build-publisher` | Maven | All versions | 1.22 |

Products: Jenkins Build-Publisher.

## How do I fix CVE-2017-1000387?

Upgrade org.jenkins-ci.plugins:build-publisher to 1.22 or later.

## Is CVE-2017-1000387 being exploited?

There is no known exploitation of CVE-2017-1000387 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-41232](https://insights.sbomify.com/CVE-2022-41232/): Jenkins build-publisher plugin vulnerable to cross-site request forgery (high 8.0)
- [CVE-2022-41231](https://insights.sbomify.com/CVE-2022-41231/): Path traversal in Jenkins build-publisher Plugin (medium 5.7)
- [CVE-2022-41230](https://insights.sbomify.com/CVE-2022-41230/): Missing permission check in Jenkins build-publisher Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000387 and fix it if it is affected.

What it is: CVE-2017-1000387 is a high-severity vulnerability in n/a, published on 26 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000387 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:build-publisher (Maven): affected all versions; fixed in 1.22
- org.jenkins-ci.plugins:build-publisher (Maven): affected all versions; fixed in 1.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000387/ (Markdown: https://insights.sbomify.com/CVE-2017-1000387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000387
- OSV: https://osv.dev/vulnerability/CVE-2017-1000387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000387/
Summaries are generated and may contain mistakes; the official description above is the record.
