{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:depgraph-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000388 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:depgraph-view to 0.13 or later.","what":"CVE-2017-1000388 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000388 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000388 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000388 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.13\n- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000388/ (Markdown: https://insights.sbomify.com/CVE-2017-1000388/index.md)","id":"CVE-2017-1000388","markdown":"https://insights.sbomify.com/CVE-2017-1000388/index.md","name":"CVE-2017-1000388","record":{"aliases":["GHSA-vhh3-mvc4-hhq6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with read access can modify dependency graph data due to missing permission checks in the Jenkins Dependency Graph Viewer plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dependency_graph_viewer","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks for the API endpoint that modifies the dependency graph, allowing anyone with Overall/Read permission to modify this data.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks","id":"CVE-2017-1000388","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-Site Request Forgery (CSRF) vulnerability in Jenkins global-build-stats plugin","id":"CVE-2017-1000389"},"packages":[{"ecosystem":"Maven","fixed":["0.13"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:depgraph-view","purl":null,"source":"GHSA-vhh3-mvc4-hhq6"},{"ecosystem":"Maven","fixed":["0.13"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:depgraph-view","purl":"pkg:maven/org.jenkins-ci.plugins/depgraph-view","source":"GHSA-vhh3-mvc4-hhq6"}],"prev":{"headline":"Jenkins Build-Publisher plugin has Insufficiently Protected Credentials","id":"CVE-2017-1000387"},"products":["n/a"],"published":"2018-01-26","related":[{"cvss_score":5.4,"headline":"Jenkins Dependency Graph Viewer Plugin contains Cross-site Scripting","id":"CVE-2019-10349","kev_date_added":null,"published":"2019-07-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers with read access can modify dependency graph data due to missing permission checks in the Jenkins Dependency Graph Viewer plugin.","url":"https://insights.sbomify.com/CVE-2017-1000388/"}