# CVE-2017-1000388: Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks

> Attackers with read access can modify dependency graph data due to missing permission checks in the Jenkins Dependency Graph Viewer plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-vhh3-mvc4-hhq6

## What is CVE-2017-1000388?

CVE-2017-1000388 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks for the API endpoint that modifies the dependency graph, allowing anyone with Overall/Read permission to modify this data.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-1000388?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:depgraph-view. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:depgraph-view` | Maven | All versions | 0.13 |
| `org.jenkins-ci.plugins:depgraph-view` | Maven | All versions | 0.13 |

Products: Jenkins Dependency Graph Viewer.

## How do I fix CVE-2017-1000388?

Upgrade org.jenkins-ci.plugins:depgraph-view to 0.13 or later.

## Is CVE-2017-1000388 being exploited?

There is no known exploitation of CVE-2017-1000388 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-10349](https://insights.sbomify.com/CVE-2019-10349/): Jenkins Dependency Graph Viewer Plugin contains Cross-site Scripting (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000388 and fix it if it is affected.

What it is: CVE-2017-1000388 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000388 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.13
- org.jenkins-ci.plugins:depgraph-view (Maven): affected all versions; fixed in 0.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000388/ (Markdown: https://insights.sbomify.com/CVE-2017-1000388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000388
- OSV: https://osv.dev/vulnerability/CVE-2017-1000388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000388/
Summaries are generated and may contain mistakes; the official description above is the record.
