# CVE-2017-1000390: Jenkins Multijob plugin did not check permissions in the Resume Build action

> Attackers with Job/Read permission can resume builds due to missing authorization checks in the Jenkins Multijob plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p9r2-gghq-hc57

## What is CVE-2017-1000390?

CVE-2017-1000390 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Multijob plugin version 1.25 and earlier did not check permissions in the Resume Build action, allowing anyone with Job/Read permission to resume the build.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2017-1000390?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:jenkins-multijob-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:jenkins-multijob-plugin` | Maven | All versions | 1.26 |
| `org.jenkins-ci.plugins:jenkins-multijob-plugin` | Maven | All versions | 1.26 |

Products: Jenkins Multijob.

## How do I fix CVE-2017-1000390?

Upgrade org.jenkins-ci.plugins:jenkins-multijob-plugin to 1.26 or later.

## Is CVE-2017-1000390 being exploited?

There is no known exploitation of CVE-2017-1000390 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2026-9674](https://insights.sbomify.com/CVE-2026-9674/): Jenkins Multijob Plugin has a cross-site request forgery (CSRF) vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000390 and fix it if it is affected.

What it is: CVE-2017-1000390 is a medium-severity missing authorization vulnerability in n/a, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000390 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:jenkins-multijob-plugin (Maven): affected all versions; fixed in 1.26
- org.jenkins-ci.plugins:jenkins-multijob-plugin (Maven): affected all versions; fixed in 1.26

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000390/ (Markdown: https://insights.sbomify.com/CVE-2017-1000390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000390
- OSV: https://osv.dev/vulnerability/CVE-2017-1000390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000390/
Summaries are generated and may contain mistakes; the official description above is the record.
