CVE-2017-1000394 Improper Input Validation in Jenkins

High 7.5 Published Updated

Attackers can cause a denial of service in Jenkins by exploiting a bundled library vulnerability, requiring a patch to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000394?

CVE-2017-1000394 is a high-severity denial of service vulnerability in Jenkins Jenkins, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-fileupload library with the denial-of-service vulnerability known as CVE-2016-3092. The fix for that vulnerability has been backported to the version of the library bundled with Jenkins.

Weakness: CWE-20

Which versions are affected by CVE-2017-1000394?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84

Products include Jenkins Jenkins.

How do I fix CVE-2017-1000394?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.73.2 or 2.84.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2017-1000394 being exploited?

There is no known exploitation of CVE-2017-1000394 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-f7f6-xrwc-9c57.

Is CVE-2017-1000394 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free