CVE-2017-1000395 Exposure of Sensitive Information to an Unauthorized Actor in Jenkins

Medium 4.3 Published Updated

Attackers with read permissions can access sensitive user data like email addresses via the remote API, requiring an upgrade to restrict access.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000395?

CVE-2017-1000395 is a medium-severity vulnerability in Jenkins Jenkins, published on 26 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins 2.73.1 and earlier, 2.83 and earlier provides information about Jenkins user accounts which is generally available to anyone with Overall/Read permissions via the /user/(username)/api remote API. This included e.g. Jenkins users' email addresses if the Mailer Plugin is installed. The remote API now no longer includes information beyond the most basic (user ID and name) unless the user requesting it is a Jenkins administrator.

Weakness: CWE-200

Which versions are affected by CVE-2017-1000395?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84

Products include Jenkins Jenkins.

How do I fix CVE-2017-1000395?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.73.2 or 2.84.

Is CVE-2017-1000395 being exploited?

There is no known exploitation of CVE-2017-1000395 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-wqv4-9gr3-3qgh.

Is CVE-2017-1000395 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free