CVE-2017-1000396 Improper Certificate Validation in Jenkins

Medium 5.9 Published Updated

Jenkins bundled a library with improper SSL certificate validation, allowing man-in-the-middle attacks to intercept or modify traffic.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000396?

CVE-2017-1000396 is a medium-severity vulnerability in Jenkins Jenkins, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins 2.73.1 and earlier, 2.83 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. This library is widely used as a transitive dependency in Jenkins plugins. The fix for CVE-2012-6153 was backported to the version of commons-httpclient that is bundled in core and made available to plugins.

Weakness: CWE-295

Which versions are affected by CVE-2017-1000396?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenAll versions2.73.2
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84
org.jenkins-ci.main:jenkins-core MavenFrom 2.742.84

Products include Jenkins Jenkins.

How do I fix CVE-2017-1000396?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.73.2 or 2.84.

Is CVE-2017-1000396 being exploited?

There is no known exploitation of CVE-2017-1000396 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-fq9f-9wv9-rfmg.

Is CVE-2017-1000396 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free