{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.main:maven-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000397 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:maven-plugin to 3.0 or later.","what":"CVE-2017-1000397 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000397 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000397 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000397 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.0\n- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000397/ (Markdown: https://insights.sbomify.com/CVE-2017-1000397/index.md)","id":"CVE-2017-1000397","markdown":"https://insights.sbomify.com/CVE-2017-1000397/index.md","name":"CVE-2017-1000397","record":{"aliases":["GHSA-qhxw-54m9-6wwc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Maven Plugin","requires_auth":"none","summary":"Man-in-the-middle attacks are possible due to incorrect SSL certificate verification in the bundled commons-httpclient library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"maven","vendor":"jenkins"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MitM on Jenkins Maven Plugin","id":"CVE-2017-1000397","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins","id":"CVE-2017-1000398"},"packages":[{"ecosystem":"Maven","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:maven-plugin","purl":null,"source":"GHSA-qhxw-54m9-6wwc"},{"ecosystem":"Maven","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:maven-plugin","purl":"pkg:maven/org.jenkins-ci.main/maven-plugin","source":"GHSA-qhxw-54m9-6wwc"}],"prev":{"headline":"Improper Certificate Validation in Jenkins","id":"CVE-2017-1000396"},"products":["n/a"],"published":"2018-01-26","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin","id":"CVE-2019-16550","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":8.1,"headline":"Jenkins Maven Release Plug-in Plugin XXE vulnerability","id":"CVE-2019-16549","kev_date_added":null,"published":"2019-12-17"},{"cvss_score":6.5,"headline":"Maven Integration Plugin did not mask sensitive values in module build logs","id":"CVE-2019-10358","kev_date_added":null,"published":"2019-07-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Man-in-the-middle attacks are possible due to incorrect SSL certificate verification in the bundled commons-httpclient library.","url":"https://insights.sbomify.com/CVE-2017-1000397/"}