# CVE-2017-1000397: MitM on Jenkins Maven Plugin

> Man-in-the-middle attacks are possible due to incorrect SSL certificate verification in the bundled commons-httpclient library.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-qhxw-54m9-6wwc

## What is CVE-2017-1000397?

CVE-2017-1000397 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-1000397?

2 open source packages ship an affected version, including org.jenkins-ci.main:maven-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:maven-plugin` | Maven | All versions | 3.0 |
| `org.jenkins-ci.main:maven-plugin` | Maven | All versions | 3.0 |

Products: Jenkins Maven.

## How do I fix CVE-2017-1000397?

Upgrade org.jenkins-ci.main:maven-plugin to 3.0 or later.

## Is CVE-2017-1000397 being exploited?

There is no known exploitation of CVE-2017-1000397 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2019-16550](https://insights.sbomify.com/CVE-2019-16550/): Cross-site request forgery (CSRF) vulnerability in Jenkins Maven Release Plugin (high 8.8)
- [CVE-2019-16549](https://insights.sbomify.com/CVE-2019-16549/): Jenkins Maven Release Plug-in Plugin XXE vulnerability (high 8.1)
- [CVE-2019-10358](https://insights.sbomify.com/CVE-2019-10358/): Maven Integration Plugin did not mask sensitive values in module build logs (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000397 and fix it if it is affected.

What it is: CVE-2017-1000397 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000397 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.0
- org.jenkins-ci.main:maven-plugin (Maven): affected all versions; fixed in 3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000397/ (Markdown: https://insights.sbomify.com/CVE-2017-1000397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000397
- OSV: https://osv.dev/vulnerability/CVE-2017-1000397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000397/
Summaries are generated and may contain mistakes; the official description above is the record.
