# CVE-2017-1000401: Improper Input Validation in Jenkins

> Attackers with log access can read secrets because Jenkins sent form validation data via GET in non-default configurations.

- **Severity:** Low 2.2 (`CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-h8c5-c92g-jq6x

## What is CVE-2017-1000401?

CVE-2017-1000401 is a low-severity vulnerability in Jenkins Jenkins, published on 26 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The Jenkins 2.73.1 and earlier, 2.83 and earlier default form control for passwords and other secrets, <f:password/>, supports form validation (e.g. for API keys). The form validation AJAX requests were sent via GET, which could result in secrets being logged to a HTTP access log in non-default configurations of Jenkins, and made available to users with access to these log files. Form validation for <f:password/> is now always sent via POST, which is typically not logged.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-1000401?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.73.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.73.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.74 | 2.84 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.74 | 2.84 |

Products: Jenkins Jenkins.

## How do I fix CVE-2017-1000401?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.73.2 or 2.84.

## Is CVE-2017-1000401 being exploited?

There is no known exploitation of CVE-2017-1000401 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000401 and fix it if it is affected.

What it is: CVE-2017-1000401 is a low-severity vulnerability in Jenkins Jenkins, published on 26 Jan 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000401 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.73.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.73.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.74; fixed in 2.84
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.74; fixed in 2.84

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000401/ (Markdown: https://insights.sbomify.com/CVE-2017-1000401/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000401
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000401
- OSV: https://osv.dev/vulnerability/CVE-2017-1000401

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000401/
Summaries are generated and may contain mistakes; the official description above is the record.
