# CVE-2017-1000402: Jenkins Swarm Plugin Client vulnerable to man-in-the-middle attacks

> Jenkins Swarm Plugin Client uses a vulnerable library that fails to verify SSL certificates, allowing attackers to intercept traffic via man-in-the-middle attacks.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pj45-8vhc-mh2f

## What is CVE-2017-1000402?

CVE-2017-1000402 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Swarm Plugin Client 3.4 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-1000402?

4 open source packages ship an affected version, including org.jenkins-ci.plugins:swarm-client and org.jvnet.hudson.plugins:swarm-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:swarm-client` | Maven | All versions | 3.5 |
| `org.jenkins-ci.plugins:swarm-client` | Maven | All versions | 3.5 |
| `org.jvnet.hudson.plugins:swarm-plugin` | Maven | All versions to 1.5 | None |
| `org.jvnet.hudson.plugins:swarm-plugin` | Maven | All versions to 1.5 | None |

Products: Jenkins Swarm.

## How do I fix CVE-2017-1000402?

Upgrade org.jenkins-ci.plugins:swarm-client to 3.5 or later.

## Is CVE-2017-1000402 being exploited?

There is no known exploitation of CVE-2017-1000402 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000402 and fix it if it is affected.

What it is: CVE-2017-1000402 is a medium-severity vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000402 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:swarm-client (Maven): affected all versions; fixed in 3.5
- org.jenkins-ci.plugins:swarm-client (Maven): affected all versions; fixed in 3.5
- org.jvnet.hudson.plugins:swarm-plugin (Maven): affected all versions up to 1.5; no fix listed
- org.jvnet.hudson.plugins:swarm-plugin (Maven): affected all versions up to 1.5; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000402/ (Markdown: https://insights.sbomify.com/CVE-2017-1000402/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000402
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000402
- OSV: https://osv.dev/vulnerability/CVE-2017-1000402

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000402/
Summaries are generated and may contain mistakes; the official description above is the record.
