{"answers":{"affected":"2 open source packages ship an affected version, including se.diabol.jenkins.pipeline:delivery-pipeline-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000404 in the wild and no public exploit code.","fix":"Upgrade se.diabol.jenkins.pipeline:delivery-pipeline-plugin to 1.0.8 or later.","what":"CVE-2017-1000404 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000404 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000404 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000404 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- se.diabol.jenkins.pipeline:delivery-pipeline-plugin (Maven): affected all versions; fixed in 1.0.8\n- se.diabol.jenkins.pipeline:delivery-pipeline-plugin (Maven): affected all versions; fixed in 1.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000404/ (Markdown: https://insights.sbomify.com/CVE-2017-1000404/index.md)","id":"CVE-2017-1000404","markdown":"https://insights.sbomify.com/CVE-2017-1000404/index.md","name":"CVE-2017-1000404","record":{"aliases":["GHSA-g364-c7w5-93wh"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Delivery Pipeline Plugin","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript in victim browsers via crafted URLs due to unescaped input in the Jenkins Delivery Pipeline Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"delivery_pipeline","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Jenkins Delivery Pipeline Plugin version 1.0.7 and earlier used the unescaped content of the query parameter 'fullscreen' in its JavaScript, resulting in a cross-site scripting vulnerability through specially crafted URLs.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Delivery Pipeline Plugin Cross-site Scripting vulnerability","id":"CVE-2017-1000404","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Race condition in n/a","id":"CVE-2017-1000405"},"packages":[{"ecosystem":"Maven","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"se.diabol.jenkins.pipeline:delivery-pipeline-plugin","purl":null,"source":"GHSA-g364-c7w5-93wh"},{"ecosystem":"Maven","fixed":["1.0.8"],"introduced":["0"],"last_affected":[],"package":"se.diabol.jenkins.pipeline:delivery-pipeline-plugin","purl":"pkg:maven/se.diabol.jenkins.pipeline/delivery-pipeline-plugin","source":"GHSA-g364-c7w5-93wh"}],"prev":{"headline":"Arbitrary code execution vulnerability in Jenkins Speaks! Plugin","id":"CVE-2017-1000403"},"products":["n/a"],"published":"2018-01-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary JavaScript in victim browsers via crafted URLs due to unescaped input in the Jenkins Delivery Pipeline Plugin.","url":"https://insights.sbomify.com/CVE-2017-1000404/"}