# CVE-2017-1000404: Jenkins Delivery Pipeline Plugin Cross-site Scripting vulnerability

> Attackers can execute arbitrary JavaScript in victim browsers via crafted URLs due to unescaped input in the Jenkins Delivery Pipeline Plugin.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-g364-c7w5-93wh

## What is CVE-2017-1000404?

CVE-2017-1000404 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The Jenkins Delivery Pipeline Plugin version 1.0.7 and earlier used the unescaped content of the query parameter 'fullscreen' in its JavaScript, resulting in a cross-site scripting vulnerability through specially crafted URLs.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000404?

2 open source packages ship an affected version, including se.diabol.jenkins.pipeline:delivery-pipeline-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `se.diabol.jenkins.pipeline:delivery-pipeline-plugin` | Maven | All versions | 1.0.8 |
| `se.diabol.jenkins.pipeline:delivery-pipeline-plugin` | Maven | All versions | 1.0.8 |

Products: Jenkins Delivery Pipeline.

## How do I fix CVE-2017-1000404?

Upgrade se.diabol.jenkins.pipeline:delivery-pipeline-plugin to 1.0.8 or later.

## Is CVE-2017-1000404 being exploited?

There is no known exploitation of CVE-2017-1000404 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000404 and fix it if it is affected.

What it is: CVE-2017-1000404 is a medium-severity cross-site scripting vulnerability in n/a, published on 26 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000404 in the wild and no public exploit code.

Affected packages and fixed versions:
- se.diabol.jenkins.pipeline:delivery-pipeline-plugin (Maven): affected all versions; fixed in 1.0.8
- se.diabol.jenkins.pipeline:delivery-pipeline-plugin (Maven): affected all versions; fixed in 1.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000404/ (Markdown: https://insights.sbomify.com/CVE-2017-1000404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000404
- OSV: https://osv.dev/vulnerability/CVE-2017-1000404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000404/
Summaries are generated and may contain mistakes; the official description above is the record.
