CVE-2017-1000419 phpBB Server-Side Request Forgery (SSRF)

High 7.5 Published Updated

An attacker can exploit a Server-Side Request Forgery vulnerability in phpBB's Remote Avatar function to scan internal ports and access internal services.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2017-1000419?

CVE-2017-1000419 is a high-severity server-side request forgery vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.

Weakness: CWE-918

Which versions are affected by CVE-2017-1000419?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.

PackageAffectedFixed in
phpbb/phpbb PackagistFrom 3.2.03.2.1
phpbb/phpbb PackagistFrom 3.2.03.2.1

Products include Phpbb Phpbb.

How do I fix CVE-2017-1000419?

Upgrade phpbb/phpbb to 3.2.1 or later.

Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.

Is CVE-2017-1000419 being exploited?

There is no known exploitation of CVE-2017-1000419 in the wild and no public exploit code.

Sources

Also known as GHSA-9jm4-rg99-566c.

Is CVE-2017-1000419 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free