{"answers":{"affected":"2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000419 in the wild and no public exploit code.","fix":"Upgrade phpbb/phpbb to 3.2.1 or later.","what":"CVE-2017-1000419 is a high-severity server-side request forgery vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000419 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000419 is a high-severity server-side request forgery vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000419 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpbb/phpbb (Packagist): affected from 3.2.0; fixed in 3.2.1\n- phpbb/phpbb (Packagist): affected from 3.2.0; fixed in 3.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000419/ (Markdown: https://insights.sbomify.com/CVE-2017-1000419/index.md)","id":"CVE-2017-1000419","markdown":"https://insights.sbomify.com/CVE-2017-1000419/index.md","name":"CVE-2017-1000419","record":{"aliases":["GHSA-9jm4-rg99-566c"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"phpBB forum software","requires_auth":"none","summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in phpBB's Remote Avatar function to scan internal ports and access internal services.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpbb","vendor":"phpbb"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpBB Server-Side Request Forgery (SSRF)","id":"CVE-2017-1000419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2017"},"n_packages":2,"n_references":2,"next":{"headline":"Syncthing vulnerable to symlink traversal and arbitrary file overwrite","id":"CVE-2017-1000420"},"packages":[{"ecosystem":"Packagist","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"phpbb/phpbb","purl":null,"source":"GHSA-9jm4-rg99-566c"},{"ecosystem":"Packagist","fixed":["3.2.1"],"introduced":["3.2.0"],"last_affected":[],"package":"phpbb/phpbb","purl":"pkg:composer/phpbb/phpbb","source":"GHSA-9jm4-rg99-566c"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2017-1000418"},"products":["n/a"],"published":"2018-01-02","related":[{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-3224","kev_date_added":null,"published":"2008-07-18"},{"cvss_score":10,"headline":"Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to \"two minor security-related bu","id":"CVE-2008-1766","kev_date_added":null,"published":"2008-04-12"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2025-70810","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2001-1471","kev_date_added":null,"published":"2005-04-21"},{"cvss_score":8.1,"headline":"phpBB has Password Reset Link Poisoning via Host Header injection","id":"CVE-2026-29199","kev_date_added":null,"published":"2026-05-04"},{"cvss_score":7.5,"headline":"phpBB arbitrary CSS injection","id":"CVE-2019-16108","kev_date_added":null,"published":"2020-03-19"},{"cvss_score":7.5,"headline":"phpBB Denial of Service","id":"CVE-2019-9826","kev_date_added":null,"published":"2019-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"An attacker can exploit a Server-Side Request Forgery vulnerability in phpBB's Remote Avatar function to scan internal ports and access internal services.","url":"https://insights.sbomify.com/CVE-2017-1000419/"}