# CVE-2017-1000419: phpBB Server-Side Request Forgery (SSRF)

> An attacker can exploit a Server-Side Request Forgery vulnerability in phpBB's Remote Avatar function to scan internal ports and access internal services.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-9jm4-rg99-566c

## What is CVE-2017-1000419?

CVE-2017-1000419 is a high-severity server-side request forgery vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2017-1000419?

2 open source packages ship an affected version, including phpbb/phpbb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpbb/phpbb` | Packagist | From 3.2.0 | 3.2.1 |
| `phpbb/phpbb` | Packagist | From 3.2.0 | 3.2.1 |

Products: Phpbb Phpbb.

## How do I fix CVE-2017-1000419?

Upgrade phpbb/phpbb to 3.2.1 or later.

## Is CVE-2017-1000419 being exploited?

There is no known exploitation of CVE-2017-1000419 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-3224](https://insights.sbomify.com/CVE-2008-3224/): Other in n/a (critical 10.0)
- [CVE-2008-1766](https://insights.sbomify.com/CVE-2008-1766/): Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack vectors, related to "two minor security-related bu (critical 10.0)
- [CVE-2025-70810](https://insights.sbomify.com/CVE-2025-70810/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2001-1471](https://insights.sbomify.com/CVE-2001-1471/): Code injection in n/a (high 8.8)
- [CVE-2026-29199](https://insights.sbomify.com/CVE-2026-29199/): phpBB has Password Reset Link Poisoning via Host Header injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000419 and fix it if it is affected.

What it is: CVE-2017-1000419 is a high-severity server-side request forgery vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000419 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpbb/phpbb (Packagist): affected from 3.2.0; fixed in 3.2.1
- phpbb/phpbb (Packagist): affected from 3.2.0; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000419/ (Markdown: https://insights.sbomify.com/CVE-2017-1000419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000419
- OSV: https://osv.dev/vulnerability/CVE-2017-1000419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000419/
Summaries are generated and may contain mistakes; the official description above is the record.
