{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2017-1000422 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2017-1000422 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000422 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000422 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000422 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000422/ (Markdown: https://insights.sbomify.com/CVE-2017-1000422/index.md)","id":"CVE-2017-1000422","markdown":"https://insights.sbomify.com/CVE-2017-1000422/index.md","name":"CVE-2017-1000422","record":{"aliases":["DEBIAN-CVE-2017-1000422","DLA-1234-1","DSA-4088-1","GHSA-245r-96m5-w336","MGASA-2018-0087","MGASA-2018-0090","SUSE-SU-2018:1950-1","UBUNTU-CVE-2017-1000422"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Gnome gdk-pixbuf library","requires_auth":"none","summary":"Integer overflows in gdk-pixbuf's GIF handling allow memory corruption and potential code execution, requiring updates to the image processing library.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"debian_linux","vendor":"debian"},{"product":"gdk-pixbuf","vendor":"gnome"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP3","SUSE:Linux Enterprise Server 12 SP3","SUSE:Linux Enterprise Server for SAP Applications 12 SP3","SUSE:Linux Enterprise Software Development Kit 12 SP3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2017-1000422","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","debian:debian_linux"],"type":"integer_overflow","year":"2017"},"n_packages":4,"n_references":5,"next":{"headline":"Code injection in n/a","id":"CVE-2017-1000423"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP3","fixed":["2.34.0-19.11.1"],"introduced":["0"],"last_affected":[],"package":"gdk-pixbuf","purl":"pkg:rpm/suse/gdk-pixbuf\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP3","source":"SUSE-SU-2018:1950-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP3","fixed":["2.34.0-19.11.1"],"introduced":["0"],"last_affected":[],"package":"gdk-pixbuf","purl":"pkg:rpm/suse/gdk-pixbuf\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP3","source":"SUSE-SU-2018:1950-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP3","fixed":["2.34.0-19.11.1"],"introduced":["0"],"last_affected":[],"package":"gdk-pixbuf","purl":"pkg:rpm/suse/gdk-pixbuf\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP3","source":"SUSE-SU-2018:1950-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP3","fixed":["2.34.0-19.11.1"],"introduced":["0"],"last_affected":[],"package":"gdk-pixbuf","purl":"pkg:rpm/suse/gdk-pixbuf\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP3","source":"SUSE-SU-2018:1950-1"}],"prev":{"headline":"Use after free in n/a","id":"CVE-2017-1000421"},"products":["n/a"],"published":"2018-01-02","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Integer overflows in gdk-pixbuf's GIF handling allow memory corruption and potential code execution, requiring updates to the image processing library.","url":"https://insights.sbomify.com/CVE-2017-1000422/"}