# CVE-2017-1000424: Electron vulnerable to URL spoofing via PDFium

> Attackers can spoof URLs when opening PDFs in Electron applications, potentially misleading users about the content source.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6h98-cf9g-vmg2

## What is CVE-2017-1000424?

CVE-2017-1000424 is a medium-severity vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Github Electron version 1.6.4 - 1.6.11 and 1.7.0 - 1.7.5 is vulnerable to a URL Spoofing problem when opening PDFs in PDFium resulting loading arbitrary PDFs that a hacker can control.

## Which versions are affected by CVE-2017-1000424?

2 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 1.7.0 | 1.7.6 |
| `electron` | npm | From 1.7.0 | 1.7.6 |

Products: Atom Electron.

## How do I fix CVE-2017-1000424?

Upgrade electron to 1.7.6 or later.

## Is CVE-2017-1000424 being exploited?

There is no known exploitation of CVE-2017-1000424 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000006](https://insights.sbomify.com/CVE-2018-1000006/): Remote Code Execution in electron (high 8.8)
- [CVE-2016-1202](https://insights.sbomify.com/CVE-2016-1202/): High severity vulnerability that affects electron (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000424 and fix it if it is affected.

What it is: CVE-2017-1000424 is a medium-severity vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000424 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 1.7.0; fixed in 1.7.6
- electron (npm): affected from 1.7.0; fixed in 1.7.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000424/ (Markdown: https://insights.sbomify.com/CVE-2017-1000424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000424
- OSV: https://osv.dev/vulnerability/CVE-2017-1000424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000424/
Summaries are generated and may contain mistakes; the official description above is the record.
