CVE-2017-1000426 MapProxy vulnerable to cross-site scripting in demo service

Medium 6.1 Published Updated

Cross-site scripting in MapProxy demo service allows attackers to disclose information via malicious scripts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000426?

CVE-2017-1000426 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

MapProxy version 1.10.3 and older is vulnerable to a Cross Site Scripting attack in the demo service resulting in possible information disclosure.

Weakness: CWE-79

Which versions are affected by CVE-2017-1000426?

3 open source packages ship an affected version, including mapproxy and MapProxy. It affects 1 product.

PackageAffectedFixed in
mapproxy PyPIAll versions1.11.1
mapproxy PyPIAll versions1.11.1
MapProxy PyPIAll versions1.11.1

Products include Omniscale Mapproxy.

How do I fix CVE-2017-1000426?

Upgrade mapproxy to 1.11.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-1000426 being exploited?

There is no known exploitation of CVE-2017-1000426 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2017-1000426, GHSA-g4rw-82hq-8jpr, PYSEC-2026-841.

Is CVE-2017-1000426 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free