{"answers":{"affected":"3 open source packages ship an affected version, including mapproxy and MapProxy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000426 in the wild and no public exploit code.","fix":"Upgrade mapproxy to 1.11.1 or later.","what":"CVE-2017-1000426 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000426 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000426 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000426 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mapproxy (PyPI): affected all versions; fixed in 1.11.1\n- mapproxy (PyPI): affected all versions; fixed in 1.11.1\n- MapProxy (PyPI): affected all versions; fixed in 1.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000426/ (Markdown: https://insights.sbomify.com/CVE-2017-1000426/index.md)","id":"CVE-2017-1000426","markdown":"https://insights.sbomify.com/CVE-2017-1000426/index.md","name":"CVE-2017-1000426","record":{"aliases":["DEBIAN-CVE-2017-1000426","GHSA-g4rw-82hq-8jpr","PYSEC-2026-841"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"MapProxy","requires_auth":"none","summary":"Cross-site scripting in MapProxy demo service allows attackers to disclose information via malicious scripts.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mapproxy","vendor":"omniscale"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"MapProxy version 1.10.3 and older is vulnerable to a Cross Site Scripting attack in the demo service resulting in possible information disclosure.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MapProxy vulnerable to cross-site scripting in demo service","id":"CVE-2017-1000426","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"Marked vulnerable to XSS from data URIs","id":"CVE-2017-1000427"},"packages":[{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"MapProxy","purl":null,"source":"GHSA-g4rw-82hq-8jpr"},{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"mapproxy","purl":"pkg:pypi/mapproxy","source":"GHSA-g4rw-82hq-8jpr"},{"ecosystem":"PyPI","fixed":["1.11.1"],"introduced":["0"],"last_affected":[],"package":"mapproxy","purl":"pkg:pypi/mapproxy","source":"PYSEC-2026-841"}],"prev":{"headline":"Liferay Portal XSS vulnerability via movie parameter in the /html/portal/flash.jsp page","id":"CVE-2017-1000425"},"products":["n/a"],"published":"2018-01-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Cross-site scripting in MapProxy demo service allows attackers to disclose information via malicious scripts.","url":"https://insights.sbomify.com/CVE-2017-1000426/"}