CVE-2017-1000427 Marked vulnerable to XSS from data URIs

Medium 6.1 Published Updated

An XSS vulnerability in the marked library's data URI parser allows attackers to execute arbitrary scripts in the context of the user's browser.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000427?

CVE-2017-1000427 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.

Weakness: CWE-79

Which versions are affected by CVE-2017-1000427?

2 open source packages ship an affected version, including marked. It affects 1 product.

PackageAffectedFixed in
marked npmAll versions0.3.7
marked npmAll versions0.3.7

Products include Marked Project Marked.

How do I fix CVE-2017-1000427?

Upgrade marked to 0.3.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-1000427 being exploited?

There is no known exploitation of CVE-2017-1000427 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2017-1000427, GHSA-7px7-7xjx-hxm8, UBUNTU-CVE-2017-1000427.

Is CVE-2017-1000427 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free