{"answers":{"affected":"2 open source packages ship an affected version, including marked. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000427 in the wild and no public exploit code.","fix":"Upgrade marked to 0.3.7 or later.","what":"CVE-2017-1000427 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000427 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000427 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000427 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- marked (npm): affected all versions; fixed in 0.3.7\n- marked (npm): affected all versions; fixed in 0.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000427/ (Markdown: https://insights.sbomify.com/CVE-2017-1000427/index.md)","id":"CVE-2017-1000427","markdown":"https://insights.sbomify.com/CVE-2017-1000427/index.md","name":"CVE-2017-1000427","record":{"aliases":["DEBIAN-CVE-2017-1000427","GHSA-7px7-7xjx-hxm8","UBUNTU-CVE-2017-1000427"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript Markdown parser","requires_auth":"none","summary":"An XSS vulnerability in the marked library's data URI parser allows attackers to execute arbitrary scripts in the context of the user's browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"marked","vendor":"marked_project"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"marked version 0.3.6 and earlier is vulnerable to an XSS attack in the data: URI parser.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Marked vulnerable to XSS from data URIs","id":"CVE-2017-1000427","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":2,"n_references":3,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000428"},"packages":[{"ecosystem":"npm","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"marked","purl":null,"source":"GHSA-7px7-7xjx-hxm8"},{"ecosystem":"npm","fixed":["0.3.7"],"introduced":["0"],"last_affected":[],"package":"marked","purl":"pkg:npm/marked","source":"GHSA-7px7-7xjx-hxm8"}],"prev":{"headline":"MapProxy vulnerable to cross-site scripting in demo service","id":"CVE-2017-1000426"},"products":["n/a"],"published":"2018-01-02","related":[{"cvss_score":8.7,"headline":"Marked: OOM Denial of Service via Infinite Recursion in marked Tokenizer","id":"CVE-2026-41680","kev_date_added":null,"published":"2026-04-24"},{"cvss_score":7.5,"headline":"Regular Expression Denial of Service in marked","id":"CVE-2017-16114","kev_date_added":null,"published":"2018-06-07"},{"cvss_score":6.9,"headline":"Regular Expression Denial of Service (ReDoS) in markedjs/marked","id":"CVE-2018-25110","kev_date_added":null,"published":"2025-05-23"},{"cvss_score":6.1,"headline":"Multiple Content Injection Vulnerabilities in marked","id":"CVE-2014-3743","kev_date_added":null,"published":"2020-01-06"},{"cvss_score":6.1,"headline":"Sanitization bypass using HTML Entities in marked","id":"CVE-2016-10531","kev_date_added":null,"published":"2018-05-31"},{"cvss_score":5.3,"headline":"Denial of Service in Marked","id":"CVE-2021-21306","kev_date_added":null,"published":"2021-02-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An XSS vulnerability in the marked library's data URI parser allows attackers to execute arbitrary scripts in the context of the user's browser.","url":"https://insights.sbomify.com/CVE-2017-1000427/"}