{"answers":{"affected":"3 open source packages ship an affected version, including base64. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000430 in the wild and no public exploit code.","fix":"Upgrade base64 to 0.5.2 or later.","what":"CVE-2017-1000430 is a critical memory corruption vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000430 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000430 is a critical memory corruption vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000430 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- base64 (crates.io): affected all versions; fixed in 0.5.2\n- base64 (crates.io): affected all versions; fixed in 0.5.2\n- base64 (crates.io): affected from 0.0.0-0; fixed in 0.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000430/ (Markdown: https://insights.sbomify.com/CVE-2017-1000430/index.md)","id":"CVE-2017-1000430","markdown":"https://insights.sbomify.com/CVE-2017-1000430/index.md","name":"CVE-2017-1000430","record":{"aliases":["GHSA-x67x-vg9m-65c3","RUSTSEC-2017-0004"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust base64 library","requires_auth":"none","summary":"A buffer overflow in the Rust base64 library allows attackers to cause memory corruption, potentially leading to code execution or crashes.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rust-base64","vendor":"rust-base64_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"rust-base64 version \u003c= 0.5.1 is vulnerable to a buffer overflow when calculating the size of a buffer to use when encoding base64 using the 'encode_config_buf' and 'encode_config' functions","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in base64","id":"CVE-2017-1000430","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"memory_corruption","year":"2017"},"n_packages":3,"n_references":1,"next":{"headline":"eZ Publish Cross-site Scripting (XSS) vulnerability","id":"CVE-2017-1000431"},"packages":[{"ecosystem":"crates.io","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"base64","purl":null,"source":"GHSA-x67x-vg9m-65c3"},{"ecosystem":"crates.io","fixed":["0.5.2"],"introduced":["0"],"last_affected":[],"package":"base64","purl":"pkg:cargo/base64","source":"GHSA-x67x-vg9m-65c3"},{"ecosystem":"crates.io","fixed":["0.5.2"],"introduced":["0.0.0-0"],"last_affected":[],"package":"base64","purl":"pkg:cargo/base64","source":"RUSTSEC-2017-0004"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000429"},"products":["n/a"],"published":"2018-01-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"A buffer overflow in the Rust base64 library allows attackers to cause memory corruption, potentially leading to code execution or crashes.","url":"https://insights.sbomify.com/CVE-2017-1000430/"}