CVE-2017-1000431 eZ Publish Cross-site Scripting (XSS) vulnerability
Attackers can inject scripts via the search module to steal authentication credentials in eZ Publish.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2017-1000431?
CVE-2017-1000431 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.
Weakness: CWE-79
Which versions are affected by CVE-2017-1000431?
4 open source packages ship an affected version, including ezsystems/ezpublish-legacy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ezsystems/ezpublish-legacy Packagist | From 5.3.0 | 5.3.12.1 |
ezsystems/ezpublish-legacy Packagist | From 5.3.0 | 5.3.12.1 |
ezsystems/ezpublish-legacy Packagist | From 5.4.0 | 5.4.10 |
ezsystems/ezpublish-legacy Packagist | From 5.4.0 | 5.4.10 |
Products include Ez Ez Publish.
How do I fix CVE-2017-1000431?
Upgrade ezsystems/ezpublish-legacy to a fixed version for your release line: 5.3.12.1 or 5.4.10.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2017-1000431 being exploited?
There is no known exploitation of CVE-2017-1000431 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-m98q-p5gq-q5ff.