{"answers":{"affected":"4 open source packages ship an affected version, including ezsystems/ezpublish-legacy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000431 in the wild and no public exploit code.","fix":"Upgrade ezsystems/ezpublish-legacy to a fixed version for your release line: 5.3.12.1 or 5.4.10.","what":"CVE-2017-1000431 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000431 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000431 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2017-1000431 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ezsystems/ezpublish-legacy (Packagist): affected from 5.3.0; fixed in 5.3.12.1\n- ezsystems/ezpublish-legacy (Packagist): affected from 5.3.0; fixed in 5.3.12.1\n- ezsystems/ezpublish-legacy (Packagist): affected from 5.4.0; fixed in 5.4.10\n- ezsystems/ezpublish-legacy (Packagist): affected from 5.4.0; fixed in 5.4.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000431/ (Markdown: https://insights.sbomify.com/CVE-2017-1000431/index.md)","id":"CVE-2017-1000431","markdown":"https://insights.sbomify.com/CVE-2017-1000431/index.md","name":"CVE-2017-1000431","record":{"aliases":["GHSA-m98q-p5gq-q5ff"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"eZ Publish CMS","requires_auth":"none","summary":"Attackers can inject scripts via the search module to steal authentication credentials in eZ Publish.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ez_publish","vendor":"ez"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"eZ Publish Cross-site Scripting (XSS) vulnerability","id":"CVE-2017-1000431","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2017"},"n_packages":4,"n_references":1,"next":{"headline":"Cross-site request forgery in n/a","id":"CVE-2017-1000432"},"packages":[{"ecosystem":"Packagist","fixed":["5.3.12.1"],"introduced":["5.3.0"],"last_affected":[],"package":"ezsystems/ezpublish-legacy","purl":null,"source":"GHSA-m98q-p5gq-q5ff"},{"ecosystem":"Packagist","fixed":["5.3.12.1"],"introduced":["5.3.0"],"last_affected":[],"package":"ezsystems/ezpublish-legacy","purl":"pkg:composer/ezsystems/ezpublish-legacy","source":"GHSA-m98q-p5gq-q5ff"},{"ecosystem":"Packagist","fixed":["5.4.10"],"introduced":["5.4.0"],"last_affected":[],"package":"ezsystems/ezpublish-legacy","purl":null,"source":"GHSA-m98q-p5gq-q5ff"},{"ecosystem":"Packagist","fixed":["5.4.10"],"introduced":["5.4.0"],"last_affected":[],"package":"ezsystems/ezpublish-legacy","purl":"pkg:composer/ezsystems/ezpublish-legacy","source":"GHSA-m98q-p5gq-q5ff"}],"prev":{"headline":"Integer overflow in base64","id":"CVE-2017-1000430"},"products":["n/a"],"published":"2018-01-02","related":[{"cvss_score":10,"headline":"Missing authorization in n/a","id":"CVE-2007-4493","kev_date_added":null,"published":"2007-08-23"},{"cvss_score":9.4,"headline":"Missing authorization in n/a","id":"CVE-2005-4853","kev_date_added":null,"published":"2007-07-06"},{"cvss_score":7.5,"headline":"Missing authorization in n/a","id":"CVE-2012-1565","kev_date_added":null,"published":"2012-10-06"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2010-2672","kev_date_added":null,"published":"2010-07-08"},{"cvss_score":7.5,"headline":"Privilege escalation in n/a","id":"CVE-2008-6844","kev_date_added":null,"published":"2009-07-02"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2012-4053","kev_date_added":null,"published":"2012-07-25"},{"cvss_score":6.8,"headline":"Cross-site scripting in n/a","id":"CVE-2003-0310","kev_date_added":null,"published":"2003-05-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can inject scripts via the search module to steal authentication credentials in eZ Publish.","url":"https://insights.sbomify.com/CVE-2017-1000431/"}