# CVE-2017-1000431: eZ Publish Cross-site Scripting (XSS) vulnerability

> Attackers can inject scripts via the search module to steal authentication credentials in eZ Publish.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-m98q-p5gq-q5ff

## What is CVE-2017-1000431?

CVE-2017-1000431 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

eZ Systems eZ Publish version 5.4.0 to 5.4.9, and 5.3.12 and older, is vulnerable to an XSS issue in the search module, resulting in a risk of attackers injecting scripts which may e.g. steal authentication credentials.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2017-1000431?

4 open source packages ship an affected version, including ezsystems/ezpublish-legacy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ezsystems/ezpublish-legacy` | Packagist | From 5.3.0 | 5.3.12.1 |
| `ezsystems/ezpublish-legacy` | Packagist | From 5.3.0 | 5.3.12.1 |
| `ezsystems/ezpublish-legacy` | Packagist | From 5.4.0 | 5.4.10 |
| `ezsystems/ezpublish-legacy` | Packagist | From 5.4.0 | 5.4.10 |

Products: Ez Ez Publish.

## How do I fix CVE-2017-1000431?

Upgrade ezsystems/ezpublish-legacy to a fixed version for your release line: 5.3.12.1 or 5.4.10.

## Is CVE-2017-1000431 being exploited?

There is no known exploitation of CVE-2017-1000431 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-4493](https://insights.sbomify.com/CVE-2007-4493/): Missing authorization in n/a (critical 10.0)
- [CVE-2005-4853](https://insights.sbomify.com/CVE-2005-4853/): Missing authorization in n/a (critical 9.4)
- [CVE-2012-1565](https://insights.sbomify.com/CVE-2012-1565/): Missing authorization in n/a (high 7.5)
- [CVE-2010-2672](https://insights.sbomify.com/CVE-2010-2672/): SQL injection in n/a (high 7.5)
- [CVE-2008-6844](https://insights.sbomify.com/CVE-2008-6844/): Privilege escalation in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000431 and fix it if it is affected.

What it is: CVE-2017-1000431 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000431 in the wild and no public exploit code.

Affected packages and fixed versions:
- ezsystems/ezpublish-legacy (Packagist): affected from 5.3.0; fixed in 5.3.12.1
- ezsystems/ezpublish-legacy (Packagist): affected from 5.3.0; fixed in 5.3.12.1
- ezsystems/ezpublish-legacy (Packagist): affected from 5.4.0; fixed in 5.4.10
- ezsystems/ezpublish-legacy (Packagist): affected from 5.4.0; fixed in 5.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000431/ (Markdown: https://insights.sbomify.com/CVE-2017-1000431/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000431
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000431
- OSV: https://osv.dev/vulnerability/CVE-2017-1000431

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000431/
Summaries are generated and may contain mistakes; the official description above is the record.
