# CVE-2017-1000433: pysaml2 Improper Authentication vulnerability

> Attackers can bypass authentication and log in as any user when the library runs with Python optimizations enabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1000433, DLA-1410-1, GHSA-924m-4pmx-c67h, PYSEC-2018-48, SUSE-SU-2018:1194-1, UBUNTU-CVE-2017-1000433, USN-3520-1

## What is CVE-2017-1000433?

CVE-2017-1000433 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pysaml2 version 4.4.0 and older accept any password when run with python optimizations enabled. This allows attackers to log in as any user without knowing their password.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2017-1000433?

3 open source packages ship an affected version, including pysaml2. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pysaml2` | PyPI | All versions | 4.5.0 |
| `pysaml2` | PyPI | All versions | 4.5.0 |
| `pysaml2` | PyPI | All versions | 4.5.0 |
| `python-pysaml2` | SUSE:OpenStack Cloud 7 | All versions | 4.0.2-3.3.2 |

Products: Debian Debian Linux, Pysaml2 Project Pysaml2.

## How do I fix CVE-2017-1000433?

Upgrade pysaml2 to 4.5.0 or later.

## Is CVE-2017-1000433 being exploited?

There is no known exploitation of CVE-2017-1000433 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000433 and fix it if it is affected.

What it is: CVE-2017-1000433 is a high-severity authentication bypass vulnerability in Debian Debian Linux, published on 2 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000433 in the wild and no public exploit code.

Affected packages and fixed versions:
- pysaml2 (PyPI): affected all versions; fixed in 4.5.0
- pysaml2 (PyPI): affected all versions; fixed in 4.5.0
- pysaml2 (PyPI): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000433/ (Markdown: https://insights.sbomify.com/CVE-2017-1000433/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000433
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000433
- OSV: https://osv.dev/vulnerability/CVE-2017-1000433

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000433/
Summaries are generated and may contain mistakes; the official description above is the record.
