CVE-2017-1000442 Passbolt API is vulnerable to XSS in the url field on the password workspace grid and sidebar

Medium 5.4 Published Updated

Attackers can inject malicious scripts via the URL field in the password workspace, potentially compromising user sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2017-1000442?

CVE-2017-1000442 is a medium-severity cross-site scripting vulnerability in n/a, published on 2 Jan 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Passbolt API version 1.6.4 and older are vulnerable to a XSS in the url field on the password workspace

Weakness: CWE-79

Which versions are affected by CVE-2017-1000442?

2 open source packages ship an affected version, including passbolt/passbolt_api. It affects 1 product.

PackageAffectedFixed in
passbolt/passbolt_api PackagistAll versions1.6.5
passbolt/passbolt_api PackagistAll versions1.6.5

Products include Passbolt Passbolt Api.

How do I fix CVE-2017-1000442?

Upgrade passbolt/passbolt_api to 1.6.5 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2017-1000442 being exploited?

There is no known exploitation of CVE-2017-1000442 in the wild and no public exploit code.

Sources

Also known as GHSA-j2fp-9wp5-mg66.

Is CVE-2017-1000442 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free