{"answers":{"affected":"2 open source packages ship an affected version, including fs-git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000451 in the wild and no public exploit code.","fix":"Upgrade fs-git to 1.0.2 or later.","what":"CVE-2017-1000451 is a high-severity command injection vulnerability in n/a, published on 2 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000451 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000451 is a high-severity command injection vulnerability in n/a, published on 2 Jan 2018. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000451 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fs-git (npm): affected all versions; fixed in 1.0.2\n- fs-git (npm): affected all versions; fixed in 1.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000451/ (Markdown: https://insights.sbomify.com/CVE-2017-1000451/index.md)","id":"CVE-2017-1000451","markdown":"https://insights.sbomify.com/CVE-2017-1000451/index.md","name":"CVE-2017-1000451","record":{"aliases":["GHSA-wp3j-gv53-4pg8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Node.js git library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via unsanitized input in fs-git library methods that use child_process.exec.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fs-git","vendor":"fs-git_project"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[],"description":"fs-git is a file system like api for git repository. The fs-git version 1.0.1 module relies on child_process.exec, however, the buildCommand method used to construct exec strings does not properly sanitize data and is vulnerable to command injection across all methods that use it and call exec.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fs-git command injection vulnerability","id":"CVE-2017-1000451","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":2,"n_references":1,"next":{"headline":"Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames","id":"CVE-2017-1000452"},"packages":[{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"fs-git","purl":null,"source":"GHSA-wp3j-gv53-4pg8"},{"ecosystem":"npm","fixed":["1.0.2"],"introduced":["0"],"last_affected":[],"package":"fs-git","purl":"pkg:npm/fs-git","source":"GHSA-wp3j-gv53-4pg8"}],"prev":{"headline":"Integer Overflow or Wraparound in OpenCV.","id":"CVE-2017-1000450"},"products":["n/a"],"published":"2018-01-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via unsanitized input in fs-git library methods that use child_process.exec.","url":"https://insights.sbomify.com/CVE-2017-1000451/"}