# CVE-2017-1000452: Samlify vulnerable to Authentication Bypass by allowing tokens to be reused with different usernames

> Attackers can impersonate arbitrary users via XML Signature Wrapping in the Samlify SAML authentication library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-8jjf-w7j6-323c

## What is CVE-2017-1000452?

CVE-2017-1000452 is a high-severity authentication bypass vulnerability in n/a, published on 2 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An XML Signature Wrapping vulnerability exists in Samlify 2.2.0 and earlier, and in predecessor Express-saml2 which could allow attackers to impersonate arbitrary users.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2017-1000452?

2 open source packages ship an affected version, including samlify. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `samlify` | npm | All versions | 2.4.0-rc5 |
| `samlify` | npm | All versions | 2.4.0-rc5 |

Products: Samlify Project Samlify.

## How do I fix CVE-2017-1000452?

Upgrade samlify to 2.4.0-rc5 or later.

## Is CVE-2017-1000452 being exploited?

There is no known exploitation of CVE-2017-1000452 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2025-47949](https://insights.sbomify.com/CVE-2025-47949/): samlify SAML Signature Wrapping attack (critical 9.9)
- [CVE-2026-46490](https://insights.sbomify.com/CVE-2026-46490/): samlify: XML Injection in AttributeValue Allows Privilege Escalation in Signed SAML Assertions (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000452 and fix it if it is affected.

What it is: CVE-2017-1000452 is a high-severity authentication bypass vulnerability in n/a, published on 2 Jan 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000452 in the wild and no public exploit code.

Affected packages and fixed versions:
- samlify (npm): affected all versions; fixed in 2.4.0-rc5
- samlify (npm): affected all versions; fixed in 2.4.0-rc5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000452/ (Markdown: https://insights.sbomify.com/CVE-2017-1000452/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000452
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000452
- OSV: https://osv.dev/vulnerability/CVE-2017-1000452

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000452/
Summaries are generated and may contain mistakes; the official description above is the record.
