CVE-2017-1000469 Cobbler vulnerable to arbitrary code execution
Attackers can execute arbitrary code as root via command injection in the add repo component of Cobbler.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2017-1000469?
CVE-2017-1000469 is a critical command injection vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.
Weakness: CWE-20
Which versions are affected by CVE-2017-1000469?
3 open source packages ship an affected version, including cobbler. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
cobbler PyPI | All versions | 3.0.0 |
cobbler PyPI | All versions | 3.0.0 |
cobbler PyPI | All versions | 3.0.0 |
Linux distribution packages (6)
cobbler SUSE:HPE Helion OpenStack 8 | All versions | 2.6.6-49.9.1 |
cobbler SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2.2.2-0.68.3.1 |
cobbler SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2.2.2-0.68.3.1 |
cobbler SUSE:Manager Client Tools 12 | All versions | 2.6.6-49.9.1 |
cobbler SUSE:Manager Server 3.0 | All versions | 2.6.6-49.9.1 |
cobbler SUSE:OpenStack Cloud 8 | All versions | 2.6.6-49.9.1 |
Products include Cobbler Project Cobbler.
How do I fix CVE-2017-1000469?
Upgrade cobbler to 3.0.0 or later.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2017-1000469 being exploited?
There is no known exploitation of CVE-2017-1000469 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2021-40323 Cobbler before 3.3.0 allows log poisoning
- CVE-2018-10931 Cobbler has Exposed Dangerous Method or Function
- CVE-2022-0860 Improper Authorization in cobbler/cobbler
- CVE-2021-45082 Command Injection in Cobbler
- CVE-2021-40324 Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.
Sources
Also known as GHSA-96hw-v598-jvgh, PYSEC-2026-314, SUSE-SU-2018:1736-1, SUSE-SU-2018:1741-1, UBUNTU-CVE-2017-1000469.