{"answers":{"affected":"3 open source packages ship an affected version, including cobbler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2017-1000469 in the wild and no public exploit code.","fix":"Upgrade cobbler to 3.0.0 or later.","what":"CVE-2017-1000469 is a critical command injection vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2017-1000469 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000469 is a critical command injection vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2017-1000469 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n- cobbler (PyPI): affected all versions; fixed in 3.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000469/ (Markdown: https://insights.sbomify.com/CVE-2017-1000469/index.md)","id":"CVE-2017-1000469","markdown":"https://insights.sbomify.com/CVE-2017-1000469/index.md","name":"CVE-2017-1000469","record":{"aliases":["GHSA-96hw-v598-jvgh","PYSEC-2026-314","SUSE-SU-2018:1736-1","SUSE-SU-2018:1741-1","UBUNTU-CVE-2017-1000469"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Cobbler provisioning server","requires_auth":"none","summary":"Attackers can execute arbitrary code as root via command injection in the add repo component of Cobbler.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cobbler","vendor":"cobbler_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the \"add repo\" component resulting in arbitrary code execution as root user.","ecosystems":["PyPI","SUSE:HPE Helion OpenStack 8","SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS","SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS","SUSE:Manager Client Tools 12","SUSE:Manager Server 3.0","SUSE:OpenStack Cloud 8"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cobbler vulnerable to arbitrary code execution","id":"CVE-2017-1000469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2017"},"n_packages":9,"n_references":1,"next":{"headline":"Integer overflow in n/a","id":"CVE-2017-1000470"},"packages":[{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":null,"source":"GHSA-96hw-v598-jvgh"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"GHSA-96hw-v598-jvgh"},{"ecosystem":"PyPI","fixed":["3.0.0"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:pypi/cobbler","source":"PYSEC-2026-314"},{"ecosystem":"SUSE:HPE Helion OpenStack 8","fixed":["2.6.6-49.9.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=HPE%20Helion%20OpenStack%208","source":"SUSE-SU-2018:1736-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS","fixed":["2.2.2-0.68.3.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP3-CLIENT-TOOLS","source":"SUSE-SU-2018:1741-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS","fixed":["2.2.2-0.68.3.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4-CLIENT-TOOLS","source":"SUSE-SU-2018:1741-1"},{"ecosystem":"SUSE:Manager Client Tools 12","fixed":["2.6.6-49.9.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Manager%20Client%20Tools%2012","source":"SUSE-SU-2018:1736-1"},{"ecosystem":"SUSE:Manager Server 3.0","fixed":["2.6.6-49.9.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20Manager%20Server%203.0","source":"SUSE-SU-2018:1736-1"},{"ecosystem":"SUSE:OpenStack Cloud 8","fixed":["2.6.6-49.9.1"],"introduced":["0"],"last_affected":[],"package":"cobbler","purl":"pkg:rpm/suse/cobbler\u0026distro=SUSE%20OpenStack%20Cloud%208","source":"SUSE-SU-2018:1736-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2017-1000468"},"products":["n/a"],"published":"2018-01-03","related":[{"cvss_score":9.8,"headline":"Cobbler before 3.3.0 allows log poisoning","id":"CVE-2021-40323","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":9.8,"headline":"Cobbler has Exposed Dangerous Method or Function","id":"CVE-2018-10931","kev_date_added":null,"published":"2018-08-09"},{"cvss_score":8.2,"headline":"Improper Authorization in cobbler/cobbler","id":"CVE-2022-0860","kev_date_added":null,"published":"2022-03-11"},{"cvss_score":7.8,"headline":"Command Injection in Cobbler","id":"CVE-2021-45082","kev_date_added":null,"published":"2022-02-18"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.","id":"CVE-2021-40324","kev_date_added":null,"published":"2021-10-04"},{"cvss_score":7.5,"headline":"Cobbler before 3.3.0 allows authorization bypass for modification of settings.","id":"CVE-2021-40325","kev_date_added":null,"published":"2021-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code as root via command injection in the add repo component of Cobbler.","url":"https://insights.sbomify.com/CVE-2017-1000469/"}