# CVE-2017-1000469: Cobbler vulnerable to arbitrary code execution

> Attackers can execute arbitrary code as root via command injection in the add repo component of Cobbler.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-96hw-v598-jvgh, PYSEC-2026-314, SUSE-SU-2018:1736-1, SUSE-SU-2018:1741-1, UBUNTU-CVE-2017-1000469

## What is CVE-2017-1000469?

CVE-2017-1000469 is a critical command injection vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2017-1000469?

3 open source packages ship an affected version, including cobbler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cobbler` | PyPI | All versions | 3.0.0 |
| `cobbler` | PyPI | All versions | 3.0.0 |
| `cobbler` | PyPI | All versions | 3.0.0 |
| `cobbler` | SUSE:HPE Helion OpenStack 8 | All versions | 2.6.6-49.9.1 |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP3-CLIENT-TOOLS | All versions | 2.2.2-0.68.3.1 |
| `cobbler` | SUSE:Linux Enterprise Server 11 SP4-CLIENT-TOOLS | All versions | 2.2.2-0.68.3.1 |
| `cobbler` | SUSE:Manager Client Tools 12 | All versions | 2.6.6-49.9.1 |
| `cobbler` | SUSE:Manager Server 3.0 | All versions | 2.6.6-49.9.1 |
| `cobbler` | SUSE:OpenStack Cloud 8 | All versions | 2.6.6-49.9.1 |

Products: Cobbler Project Cobbler.

## How do I fix CVE-2017-1000469?

Upgrade cobbler to 3.0.0 or later.

## Is CVE-2017-1000469 being exploited?

There is no known exploitation of CVE-2017-1000469 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-40323](https://insights.sbomify.com/CVE-2021-40323/): Cobbler before 3.3.0 allows log poisoning (critical 9.8)
- [CVE-2018-10931](https://insights.sbomify.com/CVE-2018-10931/): Cobbler has Exposed Dangerous Method or Function (critical 9.8)
- [CVE-2022-0860](https://insights.sbomify.com/CVE-2022-0860/): Improper Authorization in cobbler/cobbler (high 8.2)
- [CVE-2021-45082](https://insights.sbomify.com/CVE-2021-45082/): Command Injection in Cobbler (high 7.8)
- [CVE-2021-40324](https://insights.sbomify.com/CVE-2021-40324/): Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000469 and fix it if it is affected.

What it is: CVE-2017-1000469 is a critical command injection vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2017-1000469 in the wild and no public exploit code.

Affected packages and fixed versions:
- cobbler (PyPI): affected all versions; fixed in 3.0.0
- cobbler (PyPI): affected all versions; fixed in 3.0.0
- cobbler (PyPI): affected all versions; fixed in 3.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000469/ (Markdown: https://insights.sbomify.com/CVE-2017-1000469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000469
- OSV: https://osv.dev/vulnerability/CVE-2017-1000469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000469/
Summaries are generated and may contain mistakes; the official description above is the record.
