CVE-2017-1000479 Cross-site request forgery in n/a

High 8.8 Published Updated

Clickjacking in pfSense CSRF error page allows privileged arbitrary code execution due to missing X-Frame-Options header.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2017-1000479?

CVE-2017-1000479 is a high-severity vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under "possibly insecure" suspicions.

Weakness: CWE-352

Which versions are affected by CVE-2017-1000479?

It affects 2 products.

Products include Netgate Pfsense, Opnsense Project Opnsense.

How do I fix CVE-2017-1000479?

No fix has been published for CVE-2017-1000479 yet. Limit exposure of the affected software until one is available.

Is CVE-2017-1000479 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000479 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as CVE-2018-5191, GHSA-vh6j-wmcp-r6j7.

Is CVE-2017-1000479 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free