{"answers":{"affected":"It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000479 exists.","fix":"No fix has been published for CVE-2017-1000479 yet. Limit exposure of the affected software until one is available.","what":"CVE-2017-1000479 is a high-severity vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2017-1000479 and fix it if it is affected.\n\nWhat it is: CVE-2017-1000479 is a high-severity vulnerability in n/a, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2017-1000479 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2017-1000479/ (Markdown: https://insights.sbomify.com/CVE-2017-1000479/index.md)","id":"CVE-2017-1000479","markdown":"https://insights.sbomify.com/CVE-2017-1000479/index.md","name":"CVE-2017-1000479","record":{"aliases":["CVE-2018-5191","GHSA-vh6j-wmcp-r6j7"],"analysis":{"component_type":"network_device","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"pfSense firewall","requires_auth":"none","summary":"Clickjacking in pfSense CSRF error page allows privileged arbitrary code execution due to missing X-Frame-Options header.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"pfsense","vendor":"netgate"},{"product":"opnsense","vendor":"opnsense_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under \"possibly insecure\" suspicions.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2017-11-21","github_poc":0,"max_poc_stars":null,"metasploit":1,"nuclei":0,"refs":[{"date":"2017-11-21","kind":"metasploit","ref":"exploit/unix/http/pfsense_clickjacking","stars":null,"title":"Clickjacking Vulnerability In CSRF Error Page pfSense"}],"tier":"weaponised"},"has_fix":false,"headline":"Cross-site request forgery in n/a","id":"CVE-2017-1000479","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"csrf","year":"2017"},"n_packages":0,"n_references":6,"next":{"headline":"Smarty PHP code injection","id":"CVE-2017-1000480"},"packages":[],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2017-1000478"},"products":["n/a"],"published":"2018-01-03","related":[{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2019-16915","kev_date_added":null,"published":"2019-09-26"},{"cvss_score":9.6,"headline":"Cross-site scripting in n/a","id":"CVE-2020-21487","kev_date_added":null,"published":"2023-04-04"},{"cvss_score":9.3,"headline":"Cross-site scripting in n/a","id":"CVE-2024-46538","kev_date_added":null,"published":"2024-10-22"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2023-48123","kev_date_added":null,"published":"2023-12-06"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2023-42326","kev_date_added":null,"published":"2023-11-14"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2023-27253","kev_date_added":null,"published":"2023-03-17"},{"cvss_score":8.8,"headline":"Command injection in pfSense CE and pfSense Plus","id":"CVE-2022-24299","kev_date_added":null,"published":"2022-03-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Clickjacking in pfSense CSRF error page allows privileged arbitrary code execution due to missing X-Frame-Options header.","url":"https://insights.sbomify.com/CVE-2017-1000479/"}