# CVE-2017-1000481: Products.CMFPlone Open Redirect Vulnerability

> Attackers can bypass redirect restrictions to send users to malicious sites or execute JavaScript after login.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 3 Jan 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-8g72-gq68-6gqh, PYSEC-2018-70, PYSEC-2026-2963

## What is CVE-2017-1000481?

CVE-2017-1000481 is a medium-severity vulnerability in Plone Plone, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

When you visit a page where you need to login, Plone 2.5-5.1rc1 sends you to the login form with a 'came_from' parameter set to the previous url. After you login, you get redirected to the page you tried to view before. An attacker might try to abuse this by letting you click on a specially crafted link. You would login, and get redirected to the site of the attacker, letting you think that you are still on the original Plone site. Or some javascript of the attacker could be executed. Most of these types of attacks are already blocked by Plone, using the `isURLInPortal` check to make sure we only redirect to a page on the same Plone site. But a few more ways of tricking Plone into accepting a malicious link were discovered, and fixed with this hotfix.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2017-1000481?

12 open source packages ship an affected version, including products-cmfplone, Plone and Products.CMFPlone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `products-cmfplone` | PyPI | All versions | 4.3.17, 5.0.10, 5.1.0 |
| `products-cmfplone` | PyPI | All versions | 4.3.17 |
| `products-cmfplone` | PyPI | From 5.0.0 | 5.0.10 |
| `products-cmfplone` | PyPI | From 5.1a1 | 5.1.0 |
| `Plone` | PyPI | From 2.5 | 4.3.16 |
| `Plone` | PyPI | From 5 | 5.1.0 |
| `Products.CMFPlone` | PyPI | All versions | 4.3.17 |
| `Products.CMFPlone` | PyPI | From 5.0.0 | 5.0.10 |
| `Products.CMFPlone` | PyPI | From 5.1a1 | 5.1.0 |
| `plone` | PyPI | From 2.5 | 4.3.16, 5.1.0 |
| `plone` | PyPI | From 2.5 | 4.3.16 |
| `plone` | PyPI | From 5 | 5.1.0 |

Products: Plone Plone.

## How do I fix CVE-2017-1000481?

Upgrade products-cmfplone to a fixed version for your release line: 4.3.17, 5.0.10 or 5.1.0.

## Is CVE-2017-1000481 being exploited?

There is no known exploitation of CVE-2017-1000481 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000481 and fix it if it is affected.

What it is: CVE-2017-1000481 is a medium-severity vulnerability in Plone Plone, published on 3 Jan 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2017-1000481 in the wild and no public exploit code.

Affected packages and fixed versions:
- products-cmfplone (PyPI): affected all versions; fixed in 4.3.17, 5.0.10, 5.1.0
- products-cmfplone (PyPI): affected all versions; fixed in 4.3.17
- products-cmfplone (PyPI): affected from 5.0.0; fixed in 5.0.10
- products-cmfplone (PyPI): affected from 5.1a1; fixed in 5.1.0
- Plone (PyPI): affected from 2.5; fixed in 4.3.16
- Plone (PyPI): affected from 5; fixed in 5.1.0
- Products.CMFPlone (PyPI): affected all versions; fixed in 4.3.17
- Products.CMFPlone (PyPI): affected from 5.0.0; fixed in 5.0.10
- Products.CMFPlone (PyPI): affected from 5.1a1; fixed in 5.1.0
- plone (PyPI): affected from 2.5; fixed in 4.3.16, 5.1.0
- plone (PyPI): affected from 2.5; fixed in 4.3.16
- plone (PyPI): affected from 5; fixed in 5.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000481/ (Markdown: https://insights.sbomify.com/CVE-2017-1000481/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000481
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000481
- OSV: https://osv.dev/vulnerability/CVE-2017-1000481

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000481/
Summaries are generated and may contain mistakes; the official description above is the record.
