# CVE-2017-1000487: OS Command Injection in Plexus-utils


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 3 Jan 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2017-1000487, DLA-1236-1, DLA-1237-1, DSA-4146-1, DSA-4149-1, GHSA-8vhq-qq4p-grq3, SNYK-JAVA-ORGCODEHAUSPLEXUS-31522, UBUNTU-CVE-2017-1000487

## What is CVE-2017-1000487?

CVE-2017-1000487 is a critical vulnerability in Debian Debian Linux, published on 3 Jan 2018. 

### Official description

Plexus-utils before 3.0.16 is vulnerable to command injection because it does not correctly process the contents of double quoted strings.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2017-1000487?

2 open source packages ship an affected version, including org.codehaus.plexus:plexus-utils. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.codehaus.plexus:plexus-utils` | Maven | All versions | 3.0.16 |
| `org.codehaus.plexus:plexus-utils` | Maven | All versions | 3.0.16 |

Products: Codehaus-Plexus Plexus-Utils, Debian Debian Linux.

## How do I fix CVE-2017-1000487?

Upgrade org.codehaus.plexus:plexus-utils to 3.0.16 or later.

## Is CVE-2017-1000487 being exploited?

There is no known exploitation of CVE-2017-1000487 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/codehaus-plexus__plexus-utils_CVE-2017-1000487_3-0-15 (github_poc): https://github.com/shoucheng3/codehaus-plexus__plexus-utils_CVE-2017-1000487_3-0-15

## Other vulnerabilities in Debian Debian Linux

- [CVE-2025-67030](https://insights.sbomify.com/CVE-2025-67030/): Plexus-Utils has a Directory Traversal vulnerability in its extractFile method (high 8.8)
- [CVE-2022-4244](https://insights.sbomify.com/CVE-2022-4244/): Codehaus-plexus: directory traversal (high 7.5)
- [CVE-2022-4245](https://insights.sbomify.com/CVE-2022-4245/): Codehaus-plexus: xml external entity (xxe) injection (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2017-1000487 and fix it if it is affected.

What it is: CVE-2017-1000487 is a critical vulnerability in Debian Debian Linux, published on 3 Jan 2018. 
Exploitation: There is no known exploitation of CVE-2017-1000487 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.codehaus.plexus:plexus-utils (Maven): affected all versions; fixed in 3.0.16
- org.codehaus.plexus:plexus-utils (Maven): affected all versions; fixed in 3.0.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2017-1000487/ (Markdown: https://insights.sbomify.com/CVE-2017-1000487/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2017-1000487
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2017-1000487
- OSV: https://osv.dev/vulnerability/CVE-2017-1000487

---
From sbomify Insights: https://insights.sbomify.com/CVE-2017-1000487/
Summaries are generated and may contain mistakes; the official description above is the record.
